Error: "Missing DSK.dll from..." when opening SFS application

Error: "Missing DSK.dll from..." when opening SFS application

Problem

The error "Missing DSK.dll from......" pops up when trying to launch SFS for the first time after installation of the application on a new machine or when a new user profile has been created on a machine that already has SFS installed.



Environment

  1. SFS
  2. TSPOS

Solution

There are two situations where this might happen:

1. The solution to missing registry keys 

This applies for:

  1. New user profiles on existing machines that already have the application installed; or
  2. The application was installed using an Administrator account, thus the registry was written on the latter and not on the user profile that shall be using the PC or laptop.
    Follow these steps:
    1. Search for an SFS registry file (generally located in data folder named Shireburn on the server where the latter is hosted) and once found double-click on the file and press Yes when prompted
    2. If such file is not found one needs to Export registry keys from a PC/Laptop that has SFS installed and is working and then import it on the required PC/Laptop
    3. The whole process and more information can be found here: Provide access to SBS application on a new user profile  

    2. The solution to missing/wrong permissions on the application installation folder

    1. Missing permissions on application installation folder (C:\Program Files (x86)\Shireburn\). Refer to here:  How to set up Permissions on the Shireburn installation folder
    2. Try launching the application, and if the error still persists, one needs to copy DSK.dll (located in the SFS latest folder on the server where data is hosted) and paste it in C:\Program Files (x86)\Shireburn\SFS\.
      1.  This is copied automatically during the first launch of SFS application, but due to missing Security permission on the Shireburn folder in Program Files (x86), this procedure fails with the error Missing DSL.dll.

    Cause

    There are two possible causes for such error, being:
    1. Missing permissions on application installation folder (C:\Program Files (x86)\Shireburn\).
    2. Missing registry keys. This applies for:
      1. New user profiles on existing machines that already have the application installed; or
      2. The application was installed using an Administrator account, thus the registry was written on the latter and not on the user profile that shall be using the PC or laptop.

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