Re-indexing your SFM following network disconnection to fix corrupt index errors (Error 7017)

Error 7017 | Corrupt indexing error upon logging in to SFM

Problem

An SupplierSadsTable: Error 7017: Corrupt .ADI, .CDX, or .IDX index error pops up upon logging in to SFM.



Environment

SFM

Solution

A re-indexing would need to be carried out.

Before proceeding with the re-indexing, it is important that all users are logged out of both SFM & SIMS
  1. Go to SFM Administration > Reindex.
  2. Tick the System files box
  3. Click Reindex




Cause

This error normally occurs when there is a constant network disconnection.


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